$re = '/{(?<yourfield>.+)}/m';
$str = '{{My_pa{ss}word}}
{{password}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);