import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(ip|uag)=(.*)";
final String string = "fl=47f54\n"
+ "h=www.cloudflare.com\n"
+ "ip=11.111.11.11\n"
+ "ts=1597428248.652\n"
+ "visit_scheme=https\n"
+ "uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36\n"
+ "colo=OH\n"
+ "http=http/2\n"
+ "loc=US\n"
+ "tls=TLSv1.3\n"
+ "sni=plaintext\n"
+ "warp=off";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}