import re
regex = re.compile(r"^(ip|uag)=(.*)", flags=re.MULTILINE)
test_str = ("fl=47f54\n"
"h=www.cloudflare.com\n"
"ip=11.111.11.11\n"
"ts=1597428248.652\n"
"visit_scheme=https\n"
"uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36\n"
"colo=OH\n"
"http=http/2\n"
"loc=US\n"
"tls=TLSv1.3\n"
"sni=plaintext\n"
"warp=off")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")