#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)(?:\.\d+)?[^\d-]*-[^\d-]*(\d+)"
Local $sString = "sdfdsfsdffsd 16.50sd - 57676766.0sd" & @CRLF & _
"16.50sd - 57676766.0sd" & @CRLF & _
"16.50sd - 57676766.0sd" & @CRLF & _
"sdfsdffsdf 6sd - 5.989898989sd sdfsdsdf" & @CRLF & _
"sdfdsf 6.50sd - 76.50sd sdfsdfsd" & @CRLF & _
"sdfsf sd 12sd - 15sd sdfdsdffsdff" & @CRLF & _
"16.50sd - 57sd" & @CRLF & _
"16sd - 50sd" & @CRLF & _
"1.50sd - 5.0sd" & @CRLF & _
"1sd - 5766.34sd the sdfdsfdsf spesdfdsfed" & @CRLF & _
"1sd - 5766.34sd the ssdfsdf sdfsdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")