import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)(?:\\.\\d+)?[^\\d-]*-[^\\d-]*(\\d+)";
final String string = "sdfdsfsdffsd 16.50sd - 57676766.0sd\n"
+ "16.50sd - 57676766.0sd\n"
+ "16.50sd - 57676766.0sd\n"
+ "sdfsdffsdf 6sd - 5.989898989sd sdfsdsdf\n"
+ "sdfdsf 6.50sd - 76.50sd sdfsdfsd\n"
+ "sdfsf sd 12sd - 15sd sdfdsdffsdff\n"
+ "16.50sd - 57sd\n"
+ "16sd - 50sd\n"
+ "1.50sd - 5.0sd\n"
+ "1sd - 5766.34sd the sdfdsfdsf spesdfdsfed\n"
+ "1sd - 5766.34sd the ssdfsdf sdfsdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}