// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d\s(\d+\.\d+\s+)\s+(\d+\.\d+\.\d+)\s+(?P<XYZ>.*$)").unwrap();
let string = "
Number of surface maxima: 7
# a.u. eV kcal/mol X/Y/Z coordinate(Angstrom)
1 21.76342476 592.21290413656.766669 -6.892053 -0.425961 -0.514519
2 21.95275305 597.36478913775.572064 -6.167357 1.713169 -0.882468";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}