package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(test)(\s+)((abc\s+)){0,}`)
var str = `test abc abc abc abc `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}