$re = '/(test)(\s+)((abc\s+)){0,}/m';
$str = 'test abc abc abc abc ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);