const regex = /(\G(?!^)|«)([^«».!?]*)[.!?](?=[^«»]*»)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\G(?!^)|«)([^«».!?]*)[.!?](?=[^«»]*»)', 'gm')
const str = `. ? ! «abc ! and ? and .»! . ,`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);