import Foundation
let pattern = #"(\G(?!^)|«)([^«».!?]*)[.!?](?=[^«»]*»)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #". ? ! «abc ! and ? and .»! . ,"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)