# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:(25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?1)$//m;t' <<< "1.255.23.140"