re = /^(?:(25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?1)$/m
str = '1.255.23.140'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result