use strict;
my $str = '[tag1][tag4] Desired string - with optional dash [tag10]
[tag1][tag2][tag3] Desired string [tag10]
[tag3][tag1][tag2][tag5] Desired - string (with suffix)
[tag2][tag5][tag4] [Animation] Target string [tag10]
[tag3][tag1][tag5][tag10][Animations](prefix)Desired - string (and suffix)';
my $regex = qr/(?:\[Animations?\]|(?<=\]))[^\[\r\n]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}