re = /(?:\[Animations?\]|(?<=\]))[^\[\r\n]+/m
str = '[tag1][tag4] Desired string - with optional dash [tag10]
[tag1][tag2][tag3] Desired string [tag10]
[tag3][tag1][tag2][tag5] Desired - string (with suffix)
[tag2][tag5][tag4] [Animation] Target string [tag10]
[tag3][tag1][tag5][tag10][Animations](prefix)Desired - string (and suffix)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end