using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Sent: Monday, |Tuesday, |Wednesday, |Thursday, |Friday, |Saturday, |Sunday, )(\d\d|\d)\s(January |February |March |April |May |June |July |August |September |October |November |December )(20\d\d)";
string input = @"From: contactus@smartservice.qld.gov.au
Sent: Friday, 4 May 2019 7:14 AM
To: CSDirect Correspondence
Subject: Fwd: State Government Contact Form";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}