$re = '/(?<=Sent: Monday, |Tuesday, |Wednesday, |Thursday, |Friday, |Saturday, |Sunday, )(\d\d|\d)\s(January |February |March |April |May |June |July |August |September |October |November |December )(20\d\d)/m';
$str = 'From: contactus@smartservice.qld.gov.au
Sent: Friday, 4 May 2019 7:14 AM
To: CSDirect Correspondence
Subject: Fwd: State Government Contact Form';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);