#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(http(s)?:\/\/)?(www.)?([a-zA-Z0-9])+([\-\.]{1}[a-zA-Z0-9]+)*\.[a-zA-Z]{2,5}(:[0-9]{1,5})?(\/[^\s]*)?$"
Local $sString = "// valid urls" & @CRLF & _
"https://www.google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"http://google.com/" & @CRLF & _
"https://google.com/" & @CRLF & _
"www.google.com" & @CRLF & _
"google.com" & @CRLF & _
"https://www.google.com.ua" & @CRLF & _
"http://www.google.com.ua" & @CRLF & _
"http://google.com.ua" & @CRLF & _
"https://google.com.ua/" & @CRLF & _
"www.google.com.ua" & @CRLF & _
"google.com.ua" & @CRLF & _
"https://mail.google.com" & @CRLF & _
"http://mail.google.com" & @CRLF & _
"mail.google.com" & @CRLF & _
"Google.com" & @CRLF & _
"https://google.com.adaf/:%&<>\\%*&~ա\\" & @CRLF & _
"foo.ama.aa/a\sf\\" & @CRLF & _
"" & @CRLF & _
"// invalid urls" & @CRLF & _
"http://google" & @CRLF & _
"https://google.c" & @CRLF & _
"google" & @CRLF & _
"google." & @CRLF & _
".google" & @CRLF & _
".google.com" & @CRLF & _
"goole.c" & @CRLF & _
"https://google.com/ asd asdasd" & @CRLF & _
"..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")