import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http(s)?:\\/\\/)?(www.)?([a-zA-Z0-9])+([\\-\\.]{1}[a-zA-Z0-9]+)*\\.[a-zA-Z]{2,5}(:[0-9]{1,5})?(\\/[^\\s]*)?$";
final String string = "// valid urls\n"
+ "https://www.google.com\n"
+ "http://www.google.com\n"
+ "http://google.com/\n"
+ "https://google.com/\n"
+ "www.google.com\n"
+ "google.com\n"
+ "https://www.google.com.ua\n"
+ "http://www.google.com.ua\n"
+ "http://google.com.ua\n"
+ "https://google.com.ua/\n"
+ "www.google.com.ua\n"
+ "google.com.ua\n"
+ "https://mail.google.com\n"
+ "http://mail.google.com\n"
+ "mail.google.com\n"
+ "Google.com\n"
+ "https://google.com.adaf/:%&<>\\\\%*&~ա\\\\\n"
+ "foo.ama.aa/a\\sf\\\\\n\n"
+ "// invalid urls\n"
+ "http://google\n"
+ "https://google.c\n"
+ "google\n"
+ "google.\n"
+ ".google\n"
+ ".google.com\n"
+ "goole.c\n"
+ "https://google.com/ asd asdasd\n"
+ "...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}