package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\d]*)(\d+)`)
var str = `chapter02pt2.xhtml
chapter02pt2.xhtml
02_FM.xhtml
03_Title.xhtml
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}