re = /^([^\d]*)(\d+)/m
str = 'chapter02pt2.xhtml
chapter02pt2.xhtml
02_FM.xhtml
03_Title.xhtml
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end