using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[01]{1,4}";
string input = @"101010101";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}