package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[01]{1,4}`)
var str = `101010101`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}