# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/model: ([^\n]+)(.*)bitmap [^\n]+/model: $1$2bitmap $1/gms;t' <<< "# model: pmy0_footr015
filedependancy Unknown
newmodel pmy0_footr015
setsupermodel pmy0_footr015 NULL
classification Character
setanimationscale 1.0
beginmodelgeom pmy0_footr015
node dummy pmy0_footr015
parent NULL
endnode
node trimesh pmy0_footr015g
parent pmy0_footr015
position 0.0 0.0 0.0
orientation 1.0 0.0 0.0 0.0
bitmap pmh0_footr050
verts 15
-0.0378169 -0.00381612 0.00857995"