import re
regex = re.compile(r"model: ([^\n]+)(.*)bitmap [^\n]+", flags=re.MULTILINE | re.DOTALL)
test_str = ("# model: pmy0_footr015\n"
"filedependancy Unknown\n"
"newmodel pmy0_footr015\n"
"setsupermodel pmy0_footr015 NULL\n"
"classification Character\n"
"setanimationscale 1.0\n"
"beginmodelgeom pmy0_footr015\n"
"node dummy pmy0_footr015\n"
" parent NULL\n"
"endnode\n"
"node trimesh pmy0_footr015g\n"
" parent pmy0_footr015\n"
" position 0.0 0.0 0.0\n"
" orientation 1.0 0.0 0.0 0.0\n"
" bitmap pmh0_footr050\n"
" verts 15\n"
" -0.0378169 -0.00381612 0.00857995")
subst = "model: $1$2bitmap $1"
result = regex.sub(subst, test_str)
if result:
print(result)