using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/?node_modules\\(?!\boffice\b)";
string input = @"\node_modules\office\
\node_modules\image-filename-ignorenode_module
teste";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}