$re = '//?node_modules\\\\(?!\boffice\b)/m';
$str = '\\node_modules\\office\\
\\node_modules\\image-filename-ignorenode_module
teste';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);