$re = '/(?P<amount>-?\d+(?:\.\d*)?)[^\S\n]*(?P<degrees>°|deg(?:rees?)?|in)?[^\S\n]*(?P<unit>c(?:(?=el[cs]ius\b|entigrades?\b|\b))|f(?:(?=ahrenheit\b|\b))|k(?:(?=elvins?\b|\b)))/i';
$str = '70 degrees celsius
70 degree fahrenheit
70 degrees c
70 degrees f
70 ° f
70 ° c
70°c
70°f
70 deg celsius
70 deg centigrade
70 deg fahrenheit
-30.5 in Kelvin
-30.5 degrees Kelvin
-30.5 Kelvin
70F
70C
70 c
70 f
70k
100 deg celcius
Oh, it seems I have an oven from Europe. If the recipe calls for 325 degrees fahrenheit and water boils at 100 centigrades, then... multiply, and... voila! Set your oven for 650 degrees celsius--that should make your cookies crispy-brown!
# Failures
70 degrees # too ambiguous
70 deg felsius # ensure we don\'t mix fahrenheit and celsius
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);