const regex = /\s+|\(\d*\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+|\\(\\d*\\)', 'g')
const str = `+46 () 100 234567`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);