import Foundation
let pattern = #"\s+|\(\d*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"+46 () 100 234567"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)