$re = '/\A (?:\[(?=[^]]*(]\1?+)))+ ([^][]*) \1 \z/x';
$str = '[[[another text here]]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);