re = /\A (?:\[(?=[^]]*(]\1?+)))+ ([^][]*) \1 \z/x
str = '[[[another text here]]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end