package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(c|r)at`)
var str = `fat, cat, rat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}