$re = '/(c|r)at/';
$str = 'fat, cat, rat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);