$re = '/\s(?=[^,\s]*,)/m';
$str = 'Happy birthday, Jimmy
This is a test
This is, another test,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);