package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)id(\d+)`)
var str = `id123
123id`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}