$re = '/id(\d+)/m';
$str = 'id123
123id';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);