re = /\bImporting file (?:\/[^\/\n]+)*\/([^\/\n]+\.csv)\./m
str = 'Line number 12983: Importing file /user/path/abcde.csv.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end