// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bImporting file (?:/[^/\n]+)*/([^/\n]+\.csv)\.").unwrap();
let string = "Line number 12983: Importing file /user/path/abcde.csv.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}