const regex = /^([a-zA-Z]{2}[\d]{4})(?!-\d)(L\d|\sTransit|T|-[A-Z]{3})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]{2}[\\d]{4})(?!-\\d)(L\\d|\\sTransit|T|-[A-Z]{3})?$', 'gm')
const str = `# generic examples
AB1201
AB-1201
AB1201-T
AB-12-01L1
AB1201-TER
AB1201 Transit
#should match
AB1201
AB1201
AB1201T
AB1201L1
AB1201
AB1201T
AB1201-EFH
#described as an exception
AB1201-02
AB1201-02-03`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}