$re = '/^([a-zA-Z]{2}[\d]{4})(?!-\d)(L\d|\sTransit|T|-[A-Z]{3})?$/m';
$str = '# generic examples
AB1201
AB-1201
AB1201-T
AB-12-01L1
AB1201-TER
AB1201 Transit
#should match
AB1201
AB1201
AB1201T
AB1201L1
AB1201
AB1201T
AB1201-EFH
#described as an exception
AB1201-02
AB1201-02-03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);