using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"WARN.*?(?=\[C\]|$)";
string input = @"[C] L1250 WARN k2 bw34 Flex - Sockets:<16>, ThreadsPerCore:<1>
[C] L1250 WARN For abcd (analytical and transactional workloads). For 12s Systems and above, should be
disabled.
[C] L1250 INFO For abcd (analytical workloads), Hyperthreading should be enabled , 8s, 12s, 14d, 34t
d above.
[C] L1250 WARN Intel's Hyperthreading on 18+ Socket system disabled. Should be disabled urgently
fix it!
[C] L1300 OK CPU governors set as recommended
[C] L1250 WARN Intel's Hyperthreading on 8+ Socket system disabled.";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}