import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "WARN.*?(?=\\[C\\]|$)";
final String string = "[C] L1250 WARN k2 bw34 Flex - Sockets:<16>, ThreadsPerCore:<1>\n"
+ "[C] L1250 WARN For abcd (analytical and transactional workloads). For 12s Systems and above, should be\n"
+ " disabled.\n"
+ "[C] L1250 INFO For abcd (analytical workloads), Hyperthreading should be enabled , 8s, 12s, 14d, 34t\n"
+ " d above.\n"
+ "[C] L1250 WARN Intel's Hyperthreading on 18+ Socket system disabled. Should be disabled urgently\n"
+ " fix it!\n"
+ "[C] L1300 OK CPU governors set as recommended\n"
+ "[C] L1250 WARN Intel's Hyperthreading on 8+ Socket system disabled.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}