const regex = /(?:(?!.{1,30}(?:\.\s|\.$|\?\s|\?$|;\s|;$|。|?|;))(?:.{30}))|(?:.{1,30}(?:\.\s|\.$|\?\s|\?$|;\s|;$|。|?|;))/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?!.{1,30}(?:\\.\\s|\\.$|\\?\\s|\\?$|;\\s|;$|。|?|;))(?:.{30}))|(?:.{1,30}(?:\\.\\s|\\.$|\\?\\s|\\?$|;\\s|;$|。|?|;))', 'gs')
const str = `美国不仅是世界上经济最发达的国家,其教育在全球也一样是顶级水平,每年发布的世界大学排名中,有很大的一部分是来自于美国。
但是与之卓越的教育地位相对应的是高昂的学费和生活费,这对很多普通家庭来说,无疑是天价数字。
除此之外,美国留学签证和入学门槛相对其它国家而言,也更为严格。美国教育的录取规则不同于中国,很多美国名校除了学生的学.
术背景,更看重其综合实力,比如课外活动,个人经历等.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}