import re
regex = re.compile(r"\d{2}:\d{2}:\d{6,7}:\d*", flags=re.MULTILINE)
test_str = ("66:77:0066600:0000\n"
"66:11:0109003:627\n"
"66:44:0101033:378\n"
"66:27:1102019:25\n"
"66:27:1102017:6\n"
"66:27:1102033:93\n"
"66:27:1102043:21\n"
" : : :\n"
" : : :\n"
"66:11:180100:607\n"
"66:44:010101:725\n"
"66:16:260102:75\n"
"66:30:120113:163\n"
"66:30:120105:26\n"
"66:30:120106:34\n"
"66:30:120106:1\n"
"66:16:260101:3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")