$re = '/.*\.1\.\d?(6[678]|7[12]|18[012567]|301)/';
$str = '1.1.066
1.1.067
1.1.067
1.1.068
1.1.071
1.1.071
1.1.072
1.1.072
1.1.166
1.1.166
1.1.167
1.1.168
1.1.168
1.1.171
1.1.172
1.1.172
1.1.180
1.1.180
1.1.181
1.1.182
1.1.182
1.1.185
1.1.186
1.1.187
1.1.187
1.1.266
1.1.267
1.1.268
1.1.271
1.1.272
1.1.301
2.1.066
2.1.067
2.1.068
2.1.068
2.1.071
2.1.072
2.1.072
2.1.166
2.1.166
2.1.167
2.1.167
2.1.168
2.1.168
2.1.171
2.1.171
2.1.172
2.1.172
2.1.180
2.1.180
2.1.181
2.1.182
2.1.182
2.1.185
2.1.186
2.1.187
2.1.187
2.1.271
2.1.272
2.1.301';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);