import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9]+(?:[._-][a-zA-Z0-9]+)*@[a-zA-Z0-9]+\\.[a-zA-Z]{2,}$";
final String string = "_name.name_@email.com\n"
+ "-name.name-@email.com\n"
+ "name.@email.com\n"
+ "name_@email.com\n"
+ "name-@email.com\n"
+ ".name@email.com\n"
+ "_name@email.com\n"
+ "-name@email.com\n"
+ "name.name@email.com\n"
+ "name_name@email.com\n"
+ "name-name@email.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}