// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9]+(?:[._-][a-zA-Z0-9]+)*@[a-zA-Z0-9]+\.[a-zA-Z]{2,}$").unwrap();
let string = "_name.name_@email.com
-name.name-@email.com
name.@email.com
name_@email.com
name-@email.com
.name@email.com
_name@email.com
-name@email.com
name.name@email.com
name_name@email.com
name-name@email.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}