use strict;
my $str = 'Friscos #8603\\n8100 E. Orchard Road\\nGreenwood Village, Colorado 80111\\n2013-11-02\\nTable 00\\nGuest\\n1 Oysters 1/2 Shell #1\\n1 Crab Cake\\n1 Filet 1602 Bone In\\n1 Ribeye 22oz Bone In\\n1 Asparagus\\n1 Potato Au Gratin\\n$17.00\\n$19.00\\n$66.00\\n$53.00\\n$12.00\\n$11.50\\nSub Total\\nTax\\n$178.50\\n$12.94\\nTotal\\n$191.44\\n
Berghotel\\nGrosse Scheidegg\\n3818 Grindelwald\\nFamilie R. Müller\\nRech. Nr. 4572\\nBar\\n30.07.2007/13:29:17\\nTisch 7/01\\nNM\\n#ರ\\n2xLatte Macchiato à 4.50 CHF\\n1xGloki\\nà 5.00 CHF\\n1xSchweinschnitzel à 22.00 CHF\\n1xChässpätzli à 18.50 CHF\\n#ರ #ರ #1ರ\\n5.00\\n22.00\\n18.50\\nTotal:\\nCHF\\n54.50\\nIncl. 7.6% MwSt\\n54.50 CHF:\\n3.85\\nEntspricht in Euro 36.33 EUR\\nEs bediente Sie: Ursula\\nMwSt Nr. : 430 234\\nTel.: 033 853 67 16\\nFax.: 033 853 67 19\\nE-mail: grossescheidegg@bluewin.ch\\n';
my $regex = qr/(?<=\\nTotal)\:?\D+([\d\.]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}