# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\\nTotal)\:?\D+([\d\.]+)"
test_str = ("Friscos #8603\\n8100 E. Orchard Road\\nGreenwood Village, Colorado 80111\\n2013-11-02\\nTable 00\\nGuest\\n1 Oysters 1/2 Shell #1\\n1 Crab Cake\\n1 Filet 1602 Bone In\\n1 Ribeye 22oz Bone In\\n1 Asparagus\\n1 Potato Au Gratin\\n$17.00\\n$19.00\\n$66.00\\n$53.00\\n$12.00\\n$11.50\\nSub Total\\nTax\\n$178.50\\n$12.94\\nTotal\\n$191.44\\n\n\n"
"Berghotel\\nGrosse Scheidegg\\n3818 Grindelwald\\nFamilie R. Müller\\nRech. Nr. 4572\\nBar\\n30.07.2007/13:29:17\\nTisch 7/01\\nNM\\n#ರ\\n2xLatte Macchiato à 4.50 CHF\\n1xGloki\\nà 5.00 CHF\\n1xSchweinschnitzel à 22.00 CHF\\n1xChässpätzli à 18.50 CHF\\n#ರ #ರ #1ರ\\n5.00\\n22.00\\n18.50\\nTotal:\\nCHF\\n54.50\\nIncl. 7.6% MwSt\\n54.50 CHF:\\n3.85\\nEntspricht in Euro 36.33 EUR\\nEs bediente Sie: Ursula\\nMwSt Nr. : 430 234\\nTel.: 033 853 67 16\\nFax.: 033 853 67 19\\nE-mail: grossescheidegg@bluewin.ch\\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.