re = /(?:http[s]:\/\/)stackoverflow.com.*/
str = 'https://stackoverflow.com/questions/47637005/handmade-estimator-modifies-parameters-in-init/47637293?noredirect=1#comment82268544_47637293'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end